Cisco Switch ile VLANlar Arası Haberleşmeyi Kontrol Etme Nasıl Yapılır?

Cisco Switch ile VLANlar Arası Haberleşmeyi Kontrol Etme Nasıl Yapılır?

Cisco switch ile VLANlar arası haberleşmeyi kontrol etme yöntemleri ve adımları hakkında bilgi edinin. Ağınızı etkin bir şekilde yönetin.

Cisco ağ cihazları kullanılarak VLANlar arasında iletişimi kontrol etmek oldukça önemlidir. Bu makalede, Cisco omurga switch üzerinde VLANlar arası haberleşmeyi engelleme konusundaki bir örnek uygulamayı inceleyeceğiz.Öncelikle, omurga switch üzerinde VLAN’ları oluşturuyoruz ve IP adreslerini tanımlıyoruz. Ayrıca, IP yönlendirmeyi etkinleştiriyoruz. Ardından, Layer 2 switchlerde gerekli yapılandırmaları yaparak VLANlar arası haberleşmeyi kontrol edeceğiz.

1.Omurga Switch VLAN Yapılandırması:

Omurga switch, Layer 3 özelliğine sahip ve içinde iki adet VLAN (vlan 10, vlan 20) bulunduruyor. VLAN’lar arasında iletişimi kontrol etmek için şu adımları izliyoruz:

  • enable
  • conf t
  • interface range GigabitEthernet0/1-2 switchport trunk encapsulation dot1q switchport mode trunk
  • exit
  • vlan 10
  • exit
  • vlan 20
  • exit
  • interface vlan 10
  • ip address 192.168.1.1 255.255.255.0 exit
  • interface vlan 20
  • ip address 10.0.0.1 255.0.0.0
  • exit
  • ip routing

Burada, VLAN’lar arasında doğrudan iletişim olmaması için son adımda “ip routing” komutunu kullanıyoruz.

2.Layer 2 Switch VLAN Yapılandırması:

Layer 2 switchlerde de gerekli VLAN yapılandırmalarını yaparak iletişimi kontrol ediyoruz:

  • enable
  • conf t
  • vlan 10
  • exit
  • vlan 20
  • exit
  • interface
  • range FastEthernet0/1-3
  • switchport mode trunk
  • exit
  • interface FastEthernet0/2
  • switchport mode access
  • switchport access
  • vlan 10
  • exit
  • interface FastEthernet0/3
  • switchport mode access
  • switchport access
  • vlan 20 exit
  • exit
  • write memory

Bu adımlarla, Layer 2 switchlerde de VLAN yapılandırmalarını tamamlıyoruz.

3.VLANlar Arası Haberleşmeyi Engelleme:

Son olarak, omurga switch üzerinde access listeleri oluşturarak VLANlar arası iletişimi kontrol edeceğiz:

  • enable
  • conf t
  • access-list 101 deny ip 192.168.1.0 0.0.0.255 10.0.0.0 0.255.255.255
  • access-list 102 deny ip 10.0.0.0 0.255.255.255 192.168.1.0 0.0.0.255
  • interface vlan 10
  • ip access-group 101 in
  • exit
  • interface vlan 20 ip access-group 102 in exit
  • exit
  • write memory
  HTML Web Sayfalarında Alt Satıra Nasıl Geçilir?

Bu adımlarla, VLANlar arası iletişimi engelliyoruz.Sonuç olarak, bu yapılandırmalarla VLANlar arası iletişimi kontrol ederek, ağ güvenliğini artırabilir ve istenilen iletişim patikalarını belirleyebiliriz.

Cisco Switch Nedir?

Cisco switch, ağlarda veri iletimini sağlayan ve ağdaki cihazlar arasında iletişimi yöneten bir ağ cihazıdır. Genellikle Ethernet tabanlı ağlarda kullanılan bu cihazlar, farklı ağ cihazlarını birbirine bağlayarak bilgi alışverişini kolaylaştırır. Cisco, bu tür cihazların üretiminde lider bir markadır ve birçok farklı switch modeli sunmaktadır.

Switchler, bilgisayarlar, sunucular, yazıcılar ve diğer ağ cihazları arasında veri iletimini sağlar. Her bir portu ayrı bir veri yolu olarak düşünülebilir. Switchler, gelen veriyi hedefe yönlendirmek için MAC adreslerini kullanır ve bu sayede iletişimin doğrudan cihazlar arasında gerçekleşmesini sağlar. Bu, ağ trafiğini azaltarak daha etkin ve güvenli bir iletişim sağlar.

Cisco switchler, ağdaki trafik yönetimini, ağ güvenliğini, VLAN (Virtual Local Area Network) yapılandırmalarını, Quality of Service (QoS) ayarlarını ve diğer ağ özelliklerini sağlama yetenekleriyle bilinir. Bu özellikler, ağ yöneticilerine ağı verimli bir şekilde yönetme ve optimize etme imkanı sunar. Cisco switchler, büyük ölçekli kurumsal ağlardan küçük işletmelerin ihtiyaçlarına kadar geniş bir yelpazede kullanılır.

Vlan Nedir?

Virtual Local Area Network (VLAN), fiziksel ağ altyapısında bağımsız bir şekilde, mantıksal olarak bölünmüş sanal ağlardır. VLAN’lar, ağdaki cihazları fiziksel konumlarına bakılmaksızın belirli gruplara veya departmanlara göre gruplandırmanın bir yoludur. Bu gruplar, aynı VLAN içinde olan cihazlar arasında doğrudan iletişim kurabilir, fakat diğer VLAN’lardaki cihazlarla bu iletişim kısıtlanır.VLAN’lar, ağ yöneticilerine ağı daha esnek ve etkili bir şekilde yapılandırma olanağı sağlar. Farklı departmanlar, projeler veya güvenlik gereksinimleri için ayrı VLAN’lar oluşturabilir ve her birini yönetebilirler. Ayrıca, VLAN’lar ağ trafiğini izole ederek güvenlik ve performans avantajları sağlar.Bir VLAN oluşturduğunuzda, ağ cihazlarını (bilgisayarlar, yazıcılar, sunucular vb.) belirli bir grup veya proje için izole edersiniz. Bu, fiziksel ağ altyapısında bağımsız bir şekilde hareket etmelerini sağlar ve güvenlik önlemleri için etkili bir yapı sunar. VLAN’lar genellikle anahtarlar (switch’ler) aracılığıyla yönetilir ve VLAN üyelerinin trafiği, aynı VLAN içindeki diğer üyelerle paylaşılır, ancak farklı VLAN’lar arasında izolasyon sağlanır. Bu, ağdaki veri akışını daha iyi kontrol etmeyi ve güvenliği artırmayı mümkün kılar.

  Online Marketing Terimleri Nelerdir?

Cisco Switch Ne İşe Yarar?

Cisco switch, bir ağdaki cihazlar arasında veri iletimini sağlayan ve ağ trafiğini yöneten temel ağ cihazlarından biridir. Bu switch’ler, bilgisayarlar, sunucular, yazıcılar, depolama cihazları ve diğer ağ cihazları gibi ağdaki cihazlar arasında veri iletimini sağlar.

İşlevsel olarak, Cisco switch aşağıdaki görevleri gerçekleştirir:

  1. Veri Yönlendirme: Cihazlar arasında veri paketlerini yönlendirir ve hedefe iletilmesini sağlar. Bu, bilgisayarlar arasında dosya paylaşımı, internet erişimi ve diğer ağ hizmetleri için veri iletimini içerir.
  2. Ağ Trafiğini Yönetme: Cisco switch, ağ trafiğini yöneterek ağın etkinliğini ve performansını artırır. Trafiği izleyebilir, denetleyebilir ve önceliklendirebilir, böylece kritik veriler için en iyi hizmet kalitesini sağlar (QoS).
  3. Virtual LAN (VLAN) Yönetimi: VLAN’lar oluşturarak, farklı mantıksal ağlarda bulunan cihazları izole eder. Bu, ağ güvenliği ve veri gizliliği sağlama, ağ segmentasyonunu kolaylaştırma ve yönetimi esneklik sağlama açısından önemlidir.
  4. Ağ Güvenliği: Cisco switchler, ağ güvenliği için önemli bir rol oynar. Erişim kontrolleri, port tabanlı güvenlik ve güvenlik duvarı gibi özelliklerle ağı korur ve yetkisiz erişimleri engeller.
  5. Bağlantıları Yönetme: Cisco switchler, ağa bağlı cihazlar arasındaki bağlantıları yönetir, hızları ayarlar ve gerektiğinde otomatik olarak düzenler. Bu, ağın verimli çalışmasını sağlar.
  6. Ağ Yönetimi ve İzleme: Cisco switchler, ağ yöneticilerinin ağın durumunu izlemesine ve yönetmesine yardımcı olacak araçlar ve arabirimler sunar. Bu, ağ performansını takip etmek, hata ayıklamak ve yapılandırmaları güncellemek için kritiktir.

Cisco switchler, ağlarda veri iletimini, güvenliği, performansı ve esnekliği optimize etmek için önemli bir araçtır ve ağ altyapısının ana bileşenlerinden biridir.

İlginizi Çekebilir

Sanal Sunucu Kiralarken Nelere Dikkat Edilir?

Sanal Sunucu Kiralarken Nelere Dikkat Edilir?

Sanal sunucu (VDS) Hizmeti tercih ederken nelere dikkat etmeniz gerektiği , Cloud Sunucu hizmeti aldığınız firmanızın alt yapı...

Devamını Oku
PHP Nedir?

PHP Nedir?

PHP, web programlama dünyasında öne çıkan ve dinamik web sitelerinin oluşturulmasına olanak tanıyan bir dil. Nasıl doğdu ve...

Devamını Oku
Microsoft SQL Server’a (MSSQL’e) Uzak Erişim Nasıl Yapılır?

Microsoft SQL Server’a (MSSQL’e) Uzak Erişim Nasıl Yapılır?

Microsoft SQL Server’a uzaktan erişim sağlamanın adımlarını öğrenin! Uygulamanızı doğru şekilde yapılandırarak veri tabanınıza kolayca erişin. Microsoft SQL...

Devamını Oku
Domain WHOIS Gizleme Nedir? Ne İşe Yarar?

Domain WHOIS Gizleme Nedir? Ne İşe Yarar?

Domain WHOIS Gizleme hizmeti, kişisel bilgilerinizi korumak için önemli bir adımdır. Bilgisayar korsanlarının ve dolandırıcıların hedefi olmaktan kaçınmak...

Devamını Oku
Domain (Alan Adı) Nedir? Nasıl Kullanılır?

Domain (Alan Adı) Nedir? Nasıl Kullanılır?

Bir web sitesi oluştururken, sürekli olarak karşınıza çıkan bir terim olan "domain" hakkında daha fazla bilgi edinmek isteyebilirsiniz....

Devamını Oku
ICANN Nedir? Ne İşe Yarar?

ICANN Nedir? Ne İşe Yarar?

İnternetin altyapısını düzenleyen ve yöneten ICANN, internet kullanımının güvenliğini sağlamak ve düzenlemekle görevli. İşte ICANN'in önemi ve görevleri....

Devamını Oku